I suggest you ...

Make Google Map options filterable so we can disable map scrolling

With the map at 100% page width, often when you scroll the page, as your cursor goes over the map you end up zooming the map instead of scrolling the page.

Implementing an option to add a disable scroll zooming in the google map API is fairly minor, and I've included a diff below to add the option to the control panel, and implemented it on the map.

https://gist.github.com/Indemnity83/085556324241968dc529

14 votes
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    I agree to the terms of service
    Signed in as (Sign out)

    We’ll send you updates on this idea

    Kyle Klaus shared this idea  ·   ·  Admin →

    8 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      I agree to the terms of service
      Signed in as (Sign out)
      Submitting...
      • Marc commented  · 

        Still looking for an elegant solution to this. Any sign of it in 4.0?

      • Emily Johnson commented  · 

        Just wanted to chime in here... I agree that the there should be an option added to disable the map scrolling.

        Alternatively "scrollwheel: false" should just be set by default. IMHO it's a feature that has lost its usefulness as mobile has become more prevalent.

        It poses a serious usability problem when on the single event view on a mobile device and you're trying to scroll down past the google map. The user gets stuck fidgeting around with the google map. You've done such a great job with the mobile theme otherwise!

      • kuif commented  · 

        Modern tribe, your solution u provided doesnt exist!!
        You've updated the files and now its in a js file... but to that, how to disable scrolling NOW, without touching core files?? Your Guide doesn't provide a solution!

        Frustrating!!

      • Martin Taylor commented  · 

        Just a note on this - I found a way to ensure htat the zoom and streetview controls appear even in a slim view of the map ... just add this to the CSS to override the general 100% setting.

        .gmnoprint img {
        max-width: none;
        }

      • Martin Taylor commented  · 

        I've had to add these settings to embedded-map.min.js. Without them, the Google map has a slim white vertical stripe at top left, where these controls were trying to squeeze in to a very small area. Clicking this area fires up Streetview, which is unnecessary and confusing. This applies particularly to a single event view where the map is tall and narrow.

        panControl:false,zoomControl:false,rotateControl:false,streetViewControl:false

        Could you please make it possible to control these settings via the plugin, so it's unnecessary to hack the JS?

      • jason commented  · 

        the battle with this is more of mobile viewing, When your scrolling it always get's caught in map and starts moving map instead of page....

      • Gateway Development commented  · 

        Ran across this myself, and came to add a voice.

        The thought about custom coding plugins is that it’s usually a bad idea because it can cause hesitation in updating.
        A single checkbox in The Events Calendar > Settings > Map Settings that reads something like “Disable mouse-wheel scrolling in Maps”, or as Kyle has it here: "Enable Scrollwheel".

        It's the same feature as the focus in this forum post (In fact, the code to do it manually is there):
        http://tri.be/support/forums/topic/turn-off-auto-scrolling-on-google-maps/#post-17496

      Feedback and Knowledge Base